Error when loading the calendar

Found a bug?
Let me know so I can sort it out

Error when loading the calendar

Postby P-J » Tue Dec 27, 2011 11:35 pm

Hi,

I installed the calendar on my website, but when I tried to open the page, there was an error where the months should appear:

Code: Select all
Warning: mktime() expects parameter 4 to be long, string given in  (mywebsite)/ac-includes/functions.inc.php on line 20

Warning: cal_days_in_month() expects parameter 2 to be long, string given in (mywebsite)/ac-includes/functions.inc.php on line 22
ERROR checking id item availability dates
Unknown column 'NaN' in 'where clause'


Mostly 2 or 3 of the months succesfully load the first time and the other 3 continuously show the loading sign. And when I want to go to the next 6 months, this error above appears.

Do you know a possible solutition for this problem or do you need extra information?
P-J
 
Posts: 3
Joined: Tue Dec 27, 2011 11:18 pm

Re: Error when loading the calendar

Postby chris » Wed Dec 28, 2011 9:48 am

Hi,
Those errors arise when the functions in question aren't getting any data.
You say that it does load 2 or 3 months then stops.
If the calendar doesn't load completely the navigation arrows don't work as the code needs the months to be fully loaded to "know" which months to load next.

It sounds to me like your server is very slow.
Do you have an url that I can see?

Chris
User avatar
chris
Site Admin
 
Posts: 1088
Joined: Mon Dec 17, 2007 7:42 pm
Location: Málaga, Spain

Re: Error when loading the calendar

Postby P-J » Wed Dec 28, 2011 12:06 pm

P-J
 
Posts: 3
Joined: Tue Dec 27, 2011 11:18 pm

Re: Error when loading the calendar

Postby chris » Wed Dec 28, 2011 12:33 pm

Hmm, this is very strange.
As you say it appears to load the first couple of months correctly, then for some reason stops.
The error that you are getting is a 403 (forbidden) on the ajax file which makes no sense if you have already loaded it a couple of times for the first couple of months.

It looks as if, for some reason, your server is restricting the number of files that can be loaded via AJAX.
I don't know if this is possible but my knowledge of server configuration is very limited (null).
You might want to ask your hosting provider if they can explain this.

In case you haven't been able to spot it, the 403 page contents that are being returned are:
Code: Select all
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don't have permission to access /kalender/ac-includes/ajax/calendar.ajax.php
on this server.</p>
<hr>
<address>Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4.6 with Suhosin-Patch mod_perl/2.0.4 Perl/v5.10.0 Server at www.chirooskaarke.be Port 80</address>
</body></html>

As I say, seeing as it *has* worked on the 3 previous intents, this makes no sense :(

Chris
User avatar
chris
Site Admin
 
Posts: 1088
Joined: Mon Dec 17, 2007 7:42 pm
Location: Málaga, Spain

Re: Error when loading the calendar

Postby P-J » Wed Dec 28, 2011 1:04 pm

Somehow it seems that only the first 3 months can load in this calendar.

I have changed the number of months to 3 and now the calendar appears to work perfect. But when you go to the next 3 months too fast, things go wrong again....
P-J
 
Posts: 3
Joined: Tue Dec 27, 2011 11:18 pm


Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest

cron