Last updated date not displaying correctly

Found a bug?
Let me know so I can sort it out

Last updated date not displaying correctly

Postby aushol04 » Thu Jun 17, 2010 11:19 am

Calendar is great, thanks, and it did work a while ago but not sure why it won't now.
When I am in admin area and click to change the availability status of a date, it changes colour as it should. When I view it on the website though, it hasn't updated and the "date last updated" still shows as the last time it worked ie not today's date which is correct I guess seeing as it hasn't updated :?:
Cathy
aushol04
 
Posts: 6
Joined: Thu Jun 17, 2010 11:02 am

Re: Update calendar availability doesn't update website

Postby chris » Thu Jun 17, 2010 11:57 am

Hi,
yes, there is an error in the code that is not reading the update date correctly (on my "to fix" list).

Open the "ac-includes" > "functions.inc.php" file and find this lines (ln 269):
Code: Select all
$sql="SELECT DATE_FORMAT(date_mod, '".$date_format."') as date_mod FROM `".T_BOOKING_UPDATE."` WHERE id=".$id_item."";

and replace it with this:
Code: Select all
$sql="SELECT DATE_FORMAT(date_mod, '".$date_format."') as date_mod FROM `".T_BOOKING_UPDATE."` WHERE id_item=".$id_item."";


That should sort it out.
Sorry about that :(

Chris
User avatar
chris
Site Admin
 
Posts: 1088
Joined: Mon Dec 17, 2007 7:42 pm
Location: Málaga, Spain

Re: Last updated date not displaying correctly

Postby aushol04 » Sun Jun 20, 2010 1:35 am

Sorry Chris. I don't think I explained clearly. My code is correct for the date last updated bit,it is just that it actually didn't update the calendar at all, coloured availability squares or date. I am pretty sure the date will be correct if it actually does update the website. When I am in the admin area it looks great and works fine but when I click on the icon to go and view it on my actual website it hasn't changed the display. I click refresh but still nothing updated.
Cathy
aushol04
 
Posts: 6
Joined: Thu Jun 17, 2010 11:02 am

Re: Last updated date not displaying correctly

Postby aushol04 » Sun Jun 20, 2010 1:51 am

Chris,
Had another look at my database table .T_BOOKINGS_ITEMS and it has not been updated with my latest changes judging by last updated date in database table stats. So I guess there is a problem there that it is not updating my data base.
I only vaguely know what I am doingso not game to change anything directly in the database
Cathy
aushol04
 
Posts: 6
Joined: Thu Jun 17, 2010 11:02 am

Re: Last updated date not displaying correctly

Postby aushol04 » Sun Jun 20, 2010 2:03 am

Sorry, if I thought of everything at once I would be dangerous! I thought it may help you know what it states in each of the tables looking in 'phpmyadmin':
Bookings_admin_users table shows last update as today which is correct.
Bookings table shows last update as today which is correct.
Bookings_config table has not updated since day it was created which is prob OK too.
Bookings_items table has Last check as today’s date BUT last updated remains the date I created the database.
Bookings_last_update table shows last update as today which is correct.
Booking_states table has not updated since day it was created which is my problem I think.
Promise I will wait now for your answer ;)
Cathy
aushol04
 
Posts: 6
Joined: Thu Jun 17, 2010 11:02 am

Re: Last updated date not displaying correctly

Postby chris » Mon Jun 21, 2010 1:15 pm

Hi, sorry, for some reason I have not had any email alerts letting me know that you have replied to my last post. So, sorry for the delay in getting back to you :(

From what you say about the tables everthing looks to be correct.

Despiste the fact that you have sent several posts, I am having trouble understanding exactly what the problem is.
Everything looks fine in admin but not in the web?
There is no obvious reason as to why this would happen as they share the same code for actually showing the calendar.

It may be simply a paths error to the background image.
Or something has gone wrong with your implementation of the "public" calendar - how have you integrated it in your web?

Is there any chance that you could send me an url? (is this online?) - via pm if you preferred.
Also, if you have modified your admin password I would need you to send me that do (via pm)


Chris
User avatar
chris
Site Admin
 
Posts: 1088
Joined: Mon Dec 17, 2007 7:42 pm
Location: Málaga, Spain

Re: Last updated date not displaying correctly

Postby aushol04 » Fri Jun 25, 2010 2:41 pm

The path is http://www.aussieholiday.com.au/herveyb ... /index.php
My friends are setting up a Bed & Breakfast and I did a website for them using your calendar as part of it. I have put a 'booking' on the 25th and 26th June but it is not showing on the web page even though I can see it looks right in the admin site.

If it is a prob with paths error to the background image, what code am I searching for and in what file so I can locate it and see if it is correct??

I am on holidays for a couple of weeks starting tomorrow so won't be able to reply to this for a while.
aushol04
 
Posts: 6
Joined: Thu Jun 17, 2010 11:02 am

Re: Last updated date not displaying correctly

Postby chris » Fri Jun 25, 2010 2:59 pm

Hi,
Yes, it is just an error with the image path (though I don't quite understand how it can work in admin and not in the public site)
In your css file - /herveybay/calendar/ac-contents/themes/default/css/avail-calendar.css ,
this path (towards the top of the file):
Code: Select all
.cal_month ul li.booked_pr_pm   {   background-image:url("/calendar/ac-contents/themes/default/images/bg_days.png");}


Should be this:
Code: Select all
.cal_month ul li.booked_pr_pm   {   background-image:url("/herveybay/calendar/ac-contents/themes/default/images/bg_days.png");}


However I am not convinced that this is your only problem. Asides from the wrong path to the image, the dates that you say are booked are not being marked as such in the code.
Are you "sure" that these are being marked as booked in your bookings database table?

Chris
User avatar
chris
Site Admin
 
Posts: 1088
Joined: Mon Dec 17, 2007 7:42 pm
Location: Málaga, Spain

Re: Last updated date not displaying correctly

Postby aushol04 » Sun Jul 11, 2010 7:46 am

Yep that fixed it! Thanks heaps :)
aushol04
 
Posts: 6
Joined: Thu Jun 17, 2010 11:02 am


Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest