Search found 24 matches

Return to advanced search

Re: Month loading GIFs broken in IE9?

Well that's been an educational couple of days! There are all sorts of work-rounds on the Internet which are meant to force IE to redraw the screen at a given moment - trouble is, none of them seem to work. :( This morning I admitted to myself that the bottom line is the advice given by one of the f...
by kuczora
Wed Jun 29, 2011 5:43 pm
 
Forum: Bugs
Topic: Month loading GIFs broken in IE9?
Replies: 20
Views: 21291

Re: Month loading GIFs broken in IE9?

Are we talking about the next and previous month buttons? Using the select to choose another room reloads the whole page, so that shouldn't be a problem. I'll take a look at using JS to disable the next/previous buttons while the page elements are reloading. Like the idea of using JSON instead of XM...
by kuczora
Mon Jun 27, 2011 3:24 pm
 
Forum: Bugs
Topic: Month loading GIFs broken in IE9?
Replies: 20
Views: 21291

Re: Month loading GIFs broken in IE9?

Found a rather more elegant solution. In mootools-cal-public.js function load_calendar(el,month,year) set "async" to true if the browser is IE and it will behave much better. Example of my changes: // load calendar for month and year function load_calendar(el,month,year){ var sync_mode=fal...
by kuczora
Sat Jun 25, 2011 9:07 pm
 
Forum: Bugs
Topic: Month loading GIFs broken in IE9?
Replies: 20
Views: 21291

Re: Month loading GIFs broken in IE9?

The problem, as ever, is Internet Explorer and the way it renders web pages. Firefox (and I assume Safari etc) render a page progressively while it is downloading - IE displays a big fat zero until the whole page has downloaded then, bang, displays it all at once. This gives some real usability prob...
by kuczora
Sat Jun 25, 2011 5:40 pm
 
Forum: Bugs
Topic: Month loading GIFs broken in IE9?
Replies: 20
Views: 21291

Re: Month loading GIFs broken in IE9?

OK - it looks like you can get away with replacing the mootools-1.2.4-core file with the 1.2.5 equivalent.

Is working for me so far...

(Although the month loading graphics still don't appear)
by kuczora
Fri Jun 24, 2011 9:28 pm
 
Forum: Bugs
Topic: Month loading GIFs broken in IE9?
Replies: 20
Views: 21291

Re: Month loading GIFs broken in IE9?

In that case I would be more than happy to do some testing for you if it would be of help.

PS looks like there are definite issues between mootools-1.2.4 and IE9 so I'm going to plough ahead and try to get this working with 1.3.2

Yes that's definite - to support IE9 requires 1.2.5 or later
by kuczora
Thu Jun 23, 2011 9:58 pm
 
Forum: Bugs
Topic: Month loading GIFs broken in IE9?
Replies: 20
Views: 21291

Re: Month loading GIFs broken in IE9?

Just taken a look at the demo page on your site using IE9, and the mootools error doesn't occur - however the loading graphics still don't appear when changing calendars, the calendars all go blank and after 5 - 10 secs the new calendar months all appear simultaneously. Looks great in Firefox, as al...
by kuczora
Thu Jun 23, 2011 7:13 pm
 
Forum: Bugs
Topic: Month loading GIFs broken in IE9?
Replies: 20
Views: 21291

Re: Month loading GIFs broken in IE9?

I'd be glad to take a stab at moving the AAC code from mootools 1.2.4 to 1.3.2 and feeding the results back into the project if you can give me a few pointers. e.g. Which of the extras did you use in your "more" js for mootools? I'll try and find an uncompressed copy of the 1.2.4 file just...
by kuczora
Thu Jun 23, 2011 6:27 pm
 
Forum: Bugs
Topic: Month loading GIFs broken in IE9?
Replies: 20
Views: 21291

Re: Month loading GIFs broken in IE9?

Same problem occurs in IE8.

The error is at the same place in mootools, just a slightly different error message:

'a.window' is null or not an object
by kuczora
Thu Jun 23, 2011 4:50 pm
 
Forum: Bugs
Topic: Month loading GIFs broken in IE9?
Replies: 20
Views: 21291

Re: Month loading GIFs broken in IE9?

OK, back again! Looks like IE9 is breaking lots of stuff :( The date-picker error looks like issues with jQuery 1.3.2 on IE9. The failure to show the loading GIFs looks like an error in mootools1.2.4. With debugging on in IE9 I get this error: SCRIPT5007: Unable to get value of the property 'detachE...
by kuczora
Thu Jun 23, 2011 4:10 pm
 
Forum: Bugs
Topic: Month loading GIFs broken in IE9?
Replies: 20
Views: 21291
PreviousNext

Return to advanced search

cron