Page 1 of 1

Installation Issue with Version 3.03.02

PostPosted: Sun Sep 19, 2010 2:05 am
by nootkan
WHM 11.26.8
CENTOS 5.5 x86_64 standard
Kernel version 2.6.18-164.15.1.el5
cPanel Version 11.26.9
Architecture x86_64
MySQL version 5.0.91-community
Apache version 2.2.11
PHP version 5.2.10
cPanel Pro 1.0 (RC1)

I can't seem to get pass the first step after creating mysql database/username/password then clicking on my site.com/calendar and then the install link. I keep getting the:

Unable to connect to database. Please check your data.


My ac-config.inc.php file and Lang folder/contents are set to 777.

So I uploaded another open source program, created a database/username/password and the installation went fine, so I know the localhost/database/username/password config is working on my server.

When I ftp'd the ac-config.inc.php back into my computer and opened up, all the right info is there except the define ("AC_DB_PREFIX", "");

Any Ideas as to why this won't install on my server?

Re: Installation Issue with Version 3.03.02

PostPosted: Mon Sep 20, 2010 7:11 pm
by chris
Strange.
That message is only shown when you have defined the database variables (as is your case) but they are incorrect.
I know that you say that you have checked them but you might want to do so again and also try resetting your database password.

If all else fails the only thing I can suggest is that you send me your details ftp and database) and let me take a closer look. (send me via pm please)


The AC_DB_PREFIX does not need to have a value. It is just there incase you are adding the calendar tables to an eixisting database that already has tables and want to be sure that there are no conflicts with table names.

Chris

Re: Installation Issue with Version 3.03.02

PostPosted: Sun Sep 26, 2010 1:27 am
by nootkan
Alright no matter what I tried I couldn't get this to install so I deleted everything from my server and started over. Voila it worked. Not sure what went wrong but oh well it's working now. :o

Re: Installation Issue with Version 3.03.02

PostPosted: Thu Sep 30, 2010 6:06 am
by nootkan
I'm not sure if this is the reason but after trying to install ac-calendar five different times for five different domains I got the same result as before
Unable to connect to database. Please check your data.


So I thought I'd try a different password for the database. I like to use a combination of characters, numbers and Upper case in my passwords, but this time I only used Upper case mixed with characters, numbers and it seems to have worked. Example: before- $P@$$w0Rd% now- P@$$W0Rd of course that isn't the password I used but just wanted to show how I changed the sequence and it seems to work everytime I test it. Not sure if this is coincidence or an issue with the installation. I never have any problems using other opensource applications with passwords that start with characters.