Database not recognized

Help with installation and general calendar setttings

Database not recognized

Postby Zalil » Mon Sep 20, 2010 8:09 pm

Hello Chris
First thanks for the software. When all is set and working I will sure donate…
I need some guidance with installation.
Here is what I did:
1- I uploaded all files to my site: http://seashoresunset.com/calendar
2- I set “ac-config.inc.php” to:
Database host: localhost
Database name: seashoresunset
Database prefix: zalmanse (the database full name is “zalmanse_seashoresenset”)
(User and Pass too)

3- I ran: ac-install.php
But encounter: ERROR SELECTING THE DATABASE TABLE
4- Then I added the table manually as you suggested in another post.
Yet no dice… Unable to connect to database. Please check your data.

Any clue will help.
Zalil
 
Posts: 6
Joined: Mon Sep 20, 2010 3:01 pm

Re: Database not recognized

Postby chris » Mon Sep 20, 2010 8:22 pm

Hi,
Well *something* must be wrong with your database connection data.
You will need to use the fill database name (ie. zalmanse_seashoresenset - I have changed this now)
You might have to redefine your password and check all the other data.

Chris
User avatar
chris
Site Admin
 
Posts: 1089
Joined: Mon Dec 17, 2007 7:42 pm
Location: Málaga, Spain

Re: Database not recognized

Postby Zalil » Wed Sep 22, 2010 9:58 am

Do you mean to change the setup in “ac-config.inc.php” to:
Database host: localhost
Database name: zalmanse_seashoresunset
Database prefix: zalmanse

???
Zalil
 
Posts: 6
Joined: Mon Sep 20, 2010 3:01 pm

Re: Database not recognized

Postby chris » Wed Sep 22, 2010 10:22 am

No, I was referring to you double checking your database connection data (username, password and database name).
With your current settings the code is not able to connect to the database so one (or more) of those values must be wrong.
Feel free to send me a pm with your server details (ftp and "exact" database connection data) if you want me to take a look.

Chris
User avatar
chris
Site Admin
 
Posts: 1089
Joined: Mon Dec 17, 2007 7:42 pm
Location: Málaga, Spain

Re: Database not recognized

Postby chris » Wed Sep 22, 2010 10:25 am

I suspect that your username is wrong - most servers don't allow such short usernames for database access and often apend other data to the name automatically.
Of course I might be wrong ;)

Chris
User avatar
chris
Site Admin
 
Posts: 1089
Joined: Mon Dec 17, 2007 7:42 pm
Location: Málaga, Spain

Re: Database not recognized

Postby Zalil » Thu Sep 23, 2010 9:17 am

I created a new database to no avail :oops:

Let's see if I have ac-config.inc correctly:

define("AC_DB_HOST","localhost");
define("AC_DB_NAME","calendar");
define("AC_DB_USER","xx");
define("AC_DB_PASS","xx");
define("AC_DB_PREFIX","zalmanse");

A- I use an addon domain, do I still use "localhost" ?
B- The full name of the DB is zalmanse_calendar. Do I enter the full name in AC_DB_NAME? if so what about AC_DB_PREFIX?
I tried both anyway...no good...
Zalil
 
Posts: 6
Joined: Mon Sep 20, 2010 3:01 pm

Re: Database not recognized

Postby chris » Thu Sep 23, 2010 9:21 am

The db name must be the compelte name ie.zalmanse_calendar. Likewise the user name must be the complete name.
You do not need to have anything in the AC_DB_PREFIX.

Chris
User avatar
chris
Site Admin
 
Posts: 1089
Joined: Mon Dec 17, 2007 7:42 pm
Location: Málaga, Spain

Re: Database not recognized

Postby chris » Thu Sep 23, 2010 9:23 am

Fixed it.
As I suggested yesterday, your username was incomplete - it needed to have "zalmanse_" before it.

You need to take a look at your install file in the browser once more time to get the login data then don't forget to delete or rename it.

Chris
User avatar
chris
Site Admin
 
Posts: 1089
Joined: Mon Dec 17, 2007 7:42 pm
Location: Málaga, Spain

Re: Database not recognized

Postby Zalil » Thu Sep 23, 2010 11:33 am

Hi Chris,
Thank you for bearing with me on this one.
I saw that you managed to fix it. How in the world did you do that?! Did you actually hacked into my site? ;)
Zalil
 
Posts: 6
Joined: Mon Sep 20, 2010 3:01 pm

Re: Database not recognized

Postby Zalil » Thu Sep 23, 2010 11:37 am

Anyway I think I managed to mess it up again :oops:

I amended the config file as you suggested to:

define("AC_DB_HOST","localhost");
define("AC_DB_NAME","zalmanse_calendar");
define("AC_DB_USER","zalmanse_xx");
define("AC_DB_PASS","xx");
define("AC_DB_PREFIX","");

Now I get again the dreaded ERROR SELECTING THE DATABASE TABLE...

What am I doing wrong????
Zalil
 
Posts: 6
Joined: Mon Sep 20, 2010 3:01 pm

Next

Return to Support

Who is online

Users browsing this forum: No registered users and 3 guests

cron