item_id

Help with installation and general calendar setttings

item_id

Postby nathan » Fri Feb 11, 2011 11:21 pm

Hi there,

So far everything with the calendar is great. I've got the iframe working great (you can see it here - http://bluewaterretreats.com/cottages-f ... cottage=32 if you care haha) however I'm have a hard time embedding it using the php. You can see it there below the iframe, i also create this page - http://bluewaterretreats.com/calendar-test.php - which doesn't have anything on it but the code for the calendar to display. I made item_id: 2; for the var item_id in the js on this page, is there anywhere else I need to set my item id to choose the calendar to display?
nathan
 
Posts: 7
Joined: Tue Feb 08, 2011 7:20 pm

Re: item_id

Postby chris » Fri Feb 11, 2011 11:32 pm

Hi,
The first (and possibly only) error I can find with your php page is that you haven't closed the script tags.

You have this:
Code: Select all
<script type="text/javascript" src="/calendar/ac-includes/js/mootools-1.2.4-core-yc.js">
<script type="text/javascript" src="/calendar/ac-includes/js/mootools-cal-public.js">
var url_ajax_cal = '/calendar/ac-includes/ajax/calendar.ajax.php';
var img_loading_day = '/calendar/ac-contents/themes/default/images/ajax-loader-day.gif';
var img_loading_month = '/calendar/ac-contents/themes/default/images/ajax-loader-month.gif';   
var id_item =2;
var lang = 'en';
var months_to_show = 1;
var clickable_past = 'on';
</script>


whereas it should be like this:
Code: Select all
<script type="text/javascript" src="/calendar/ac-includes/js/mootools-1.2.4-core-yc.js"></script>
<script type="text/javascript" src="/calendar/ac-includes/js/mootools-cal-public.js"></script>
<script type="text/javascript">
var url_ajax_cal = '/calendar/ac-includes/ajax/calendar.ajax.php';
var img_loading_day = '/calendar/ac-contents/themes/default/images/ajax-loader-day.gif';
var img_loading_month = '/calendar/ac-contents/themes/default/images/ajax-loader-month.gif';   
var id_item =2;
var lang = 'en';
var months_to_show = 1;
var clickable_past = 'on';
</script>

OK, I know that in theory the second </script> is not needed but it keeps things simpler if it is there (and you open a new script tag for the variables). You defiantly need to close the first one.

Add that and see if it starts to work.

Chris
User avatar
chris
Site Admin
 
Posts: 1089
Joined: Mon Dec 17, 2007 7:42 pm
Location: Málaga, Spain

Re: item_id

Postby nathan » Sat Feb 12, 2011 6:09 pm

haha talk about amateur hour, that fixed it. Thanks alot!
nathan
 
Posts: 7
Joined: Tue Feb 08, 2011 7:20 pm


Return to Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron