Not showing calendar

Help with installation and general calendar setttings

Not showing calendar

Postby oxxxis » Thu Jun 10, 2010 4:15 pm

I installed the calendar and everything is working fine, but there is a problem, the calendar isn't showing up neither in the admin panel or embeded one. It just shows the availability keys and nothing more. I think it must be some kind of problem with css and js include, but where can I fix it? Thank you.
oxxxis
 
Posts: 3
Joined: Thu Jun 10, 2010 4:12 pm

Re: Not showing calendar

Postby chris » Thu Jun 10, 2010 4:30 pm

Hi,
everything is working fine, but there is a problem, the calendar isn't showing up neither in the admin panel or embeded one

How can everything be working fine if it isn't showing up? :D

Without seeing an url it is impossible to know what the problem might be.
Can you post an url?

Chris
User avatar
chris
Site Admin
 
Posts: 1089
Joined: Mon Dec 17, 2007 7:42 pm
Location: Málaga, Spain

Re: Not showing calendar

Postby oxxxis » Thu Jun 10, 2010 5:01 pm

the host name will change in couple of hours

http://if26.nano.lv/~kapaslv/index.php? ... ng&lang=lv

this is calendar index

http://if26.nano.lv/~kapaslv/calendar/

the list is booking keys in latvian (if you need, i can send the language file).
oxxxis
 
Posts: 3
Joined: Thu Jun 10, 2010 4:12 pm

Re: Not showing calendar

Postby chris » Thu Jun 10, 2010 5:10 pm

The paths to all the files (css, js, ajax) are wrong.

Have you defined the calendar url in the admin panel so that it reflects your setup?

I suspect that you have "/calendar" wheras it should be (in your case) "/~kapaslv/calendar/"

I tried logging in to admin but you have (rightly) changed the password.

Chris
User avatar
chris
Site Admin
 
Posts: 1089
Joined: Mon Dec 17, 2007 7:42 pm
Location: Málaga, Spain

Re: Not showing calendar

Postby oxxxis » Thu Jun 10, 2010 5:31 pm

Thank you! It's working now! Now I have to change language file to shorter labels and there seems to be one more problem:

Available and booked am, booked pm are in the same color, where can I change that?
oxxxis
 
Posts: 3
Joined: Thu Jun 10, 2010 4:12 pm

Re: Not showing calendar

Postby chris » Thu Jun 10, 2010 6:23 pm

They are in the css file which can be found here :
ac-contents > themes > default > css
You will need to adjust the path of the background image which is defined towards the top of the css file.

Chris
User avatar
chris
Site Admin
 
Posts: 1089
Joined: Mon Dec 17, 2007 7:42 pm
Location: Málaga, Spain

Re: Not showing calendar

Postby davidmw » Wed Jun 23, 2010 4:58 pm

I'm having the same problem, but I'm not sure if I've understood how to solve it.

The calendar is running on a local MAMP server, and index.php is placed in the root folder. Accordingly the url to the calendar is http://localhost:8888/index.php. But it only shows plain text, as shown by oxxxis' calendar index url above.

chris wrote:Have you defined the calendar url in the admin panel so that it reflects your setup?


By this, do you mean the calendar url defined next to "Path to calendar from root" in the admin panel? I've changed that to "/index.php". By doing so, the top right calendar menu icon locates to the calendar. But what should I do to be able to load the graphical representation of the calendar?

Thanks in advance!
davidmw
 
Posts: 6
Joined: Wed Jun 23, 2010 4:29 pm

Re: Not showing calendar

Postby chris » Wed Jun 23, 2010 5:59 pm

Hello,
without being able to see the calendar it is pretty hard to know what is going wrong.
The reason that oxxxis' calendar is not working is due to what I have already said - the paths are wrong.

chris wrote:Have you defined the calendar url in the admin panel so that it reflects your setup?

By this, do you mean the calendar url defined next to "Path to calendar from root" in the admin panel? I've changed that to "/index.php".

No, it needs to be the path to the calendar directory, not the index.php file.
So, if you have it set up directly in the root, it simply needs to be "/".

As I say, without being able to see the page and code, it is pretty hard to know what is going wrong.
Have you tried uploading it to a server?

Chris
User avatar
chris
Site Admin
 
Posts: 1089
Joined: Mon Dec 17, 2007 7:42 pm
Location: Málaga, Spain

Re: Not showing calendar

Postby davidmw » Wed Jun 23, 2010 8:13 pm

Thanks for the reply!

I uploaded it to a server and placed it in a subfolder, which actually did the trick. Apparently the calender couldn't be executed from the root folder. I actually had the calendar directory path set to "/" to start with, but then the calendar menu icon located me to "http:///". Entering a path (e.g. "/calendar") would generate the full url to the menu icon (e.g. "http://localhost:8888/calendar"). So by placing the calendar in a subfolder and setting the path to that directory made the graphical representation of the calendar visible.

Thanks again!
davidmw
 
Posts: 6
Joined: Wed Jun 23, 2010 4:29 pm


Return to Support

Who is online

Users browsing this forum: No registered users and 0 guests

cron